Symptoms


In an attempt to do an immediate plan upgrade for subscription to a better SKU, the following message appears in UX1:

There are no plans available for an immediate switch, but you can schedule a plan change on subscription auto-renewal.


Cause


Immediate switch not allowed:

Resolution


The possibility of doing an immediate plan upgrade to a higher SKU was implemented in the new feature request PFR-5454 and a new version of PLM 1.9.589. Before that, it was not possible due to platform limitations and was allowed during 7 days after renewal only (despite the fact that Microsoft allowed to do it in the middle of the subscription lifecycle).

Check you current PLM version and if PPR is uploaded with the correctly filled out PlanSwitchPaths sheet (ImmediateSwitchAllowed should be set as TRUE):