Symptoms


Subscription has custom name, then it is switched to different Service Plan but subscription name is still the same prior the switch plan.


Cause


According to current platform logic if a subscription name has been manually changed in UI or API then db value "Subscription"."IsNameCustom" is changed from 0 to 1. And after that if plan is switched on this subscription then new plan name will not be set to subscription name. 


Resolution


As a work around It is only possible to change subscription name manually. 

Go to Billing > Subscription > Edit > New subscription Name > Save.




If it is needed to force subscription name on switch plan there is a Feature Request PBA-56286 to improve this behavior.