Symptoms
The Azure NCE subscription import process got stuck from CB Connect with an error in the PR request
"Error on allowing the customer to view charges. : There has not been possible to identify billing account".
Cause
This message appears due to the GET request received an empty reply and it's visible from CB Connect logs:
"GET" : "https://management.azure.com/providers/Microsoft.Billing/billingAccounts/?api-version=2019-10-01-preview", x-ms-request-id:"b2d30be9-1e24-40b8-9f42-77997b6d7dcf": {'value': []}
It means a customer doesn't have a provider billing account set up with Microsoft, which is why an empty value was received.
Resolution
That needs to be fixed by a customer with Microsoft.