Symptoms
An attempt to change NCE Subscription period from Monthly to Yearly is failing with one of the following errors:
"Your order is invalid, as it contains 2 main offer(s)"
Following error occurred:400 Bad Request ConnectError(error_code=VAL_001, errors=[asset.items: Item periods are incompatible. Periods: Monthly, Yearly.], params=null)
Reproduce scenario is following:
1. Have an NCE subscription with subscription period monthly
2. From Customer UX1 >> subscription >> change >> try to change the subscription period to 1 year(s) >> click next >> change attempt failed with the error message mentioned above.
At the same time, following error can be found in PLM pod logs:
2023-04-24T06:07:36.971487364Z 24-04-2023;07:07:36,971+0100 ERROR [db1999f4-0933-50b5-f8df-234b1d573e45 application-rest:task-5379 inhouse-products] c.o.p.a.util.APSExceptionMapper - Error occurred com.ingrammicro.imcp.library.aps.exception.APSError: 400 Bad Request ConnectError(error_code=VAL_001, errors=[asset.items: Item periods are incompatible. Periods: Monthly, Yearly.], params=null)u2028
Cause
Software issue #PDI-2031.
Resolution
There is no workaround available. Contact your Account Manager to clarify the status of PDI-2031.
Install the latest PLM version.