Symptoms


In an attempt to add payment method in UX1, the error 'Current Account can not process transaction: wrong Transaction ID.' appeared after authentication process and payment method was not saved.


Cause


The error appears when L0, L1 or L2 staff member impersonates into customer, log in to customer UI and tries to create payment method or place payment. Adding stored payment method was prohibited for user other than the end customer. This action requires the customer user to login directly using his username and password and add payment method or place payment.


Resolution


End customer is required to add payment method or place payment by logging in directly using their own user and password.