Symptoms
If you login to Account and find in business > marketing > promotions > promo code no data is displayed, in the backend on the web-debugger request to fetch subscription HTTP error code 414 is displayed.
Cause
This is caused by software bug #DM-218. This promo is applied to a huge amount of subscriptions, in browser console we can observe the request has sent in the uri more than the allowed characters by default configuration, therefore get a 414 error, uri too long.
Resolution
Software bug #DM-218 will be fixed in future releases of Discount Manager.
There is an available w/a:
**Execute following command from branding-ui pod.
Option 1. temporary change (until branding-ui pod restart):
vi /etc/httpd/brand.conf.d/brand_your.brand.com.conf
add LimitRequestLine to <VirtualHost *:443>...</> . for example:
<VirtualHost *:443>
ServerName your.brand.com
LimitRequestLine 16380
To apply changes:
1. identify httpd pid
ps -ef | grep httpd | grep root | grep sbin | awk '{print $2}'
2. kill httpd pid
kill -SIGUSR1 275
Option 2. permanent change
vi /mnt/brands/vhost/brand_your.brand.com.conf
add LimitRequestLine to <VirtualHost *:443>...</> . for example:
<VirtualHost *:443>
ServerName your.brand.com
LimitRequestLine 16380
to apply changes:
/sbin/reload-httpd
Then restart pod:
kubectl delete pod -l service=branding-ui-cluster-ui