Symptoms


PPR file has been uploaded to UX1 panel to create new Service Plans. After the import no plans are added. There is a failed task in Operations side with following error message:

'500 Internal Server Error' received from 'POST https://inhouse-products:8081/rest/application/581c65a7-8d9d-4033-8708-85db2b522770/applyConfig': javax.ejb.EJBTransactionRolledbackException: Subscription Period may not be shorter than Billing Period.


Cause


Subscription Period is shorter than Billing Period on PPR file for this Service Plan. Example:

You are trying to create a Monthly based plan, in Subscription Period you set 1 Month(s), while in Billing Period you set 1 Year(s).


This means this Service Plan will be charged for an entire year even if you just purchase it for a month. This is wrong so it does not allows you to import this configuration.


Resolution


Align Subscription Period and Billing Period in PPR file, then try to upload it again from UX1 panel. If this solution does not work or prompts a new error, please contact CloudBlue Technical Support.