Symptoms


Customer is trying to import an Exclaimer Subscription into the Control panel by using the request payload:

{
"type": "MIGRATION",
"accountId": "123qwe12-1234-5678-9101-1234qwer1234",
"planId": "123qwe12-1234-5678-9101-1234qwer1234",
"period": {
"unit": "MONTHS",
"duration": "12"
},
"resources": [
{
"resourceId": "123qwe12-1234-5678-9101-1234qwer1234",
"amount": 1
}
],
"startDate": "2019-10-10",
"expirationDate": "2023-10-10",
"migrationDate": "2023-05-18",
"migrationProgram": "do_not_count_migration_billing_period",
"parameters": [
{
"aps": {
"type": "http://aps-standard.org/inhouse-products/tenant/1.0"
},
"activationParameters": [
{
"key": "subscriptionoption1",
"value": "Import"
},
{
"key": "migrationsubscriptionid",
"value": "B7psegNzU2B8WSYzPNJYEwy27Us2ND"
}
]
}
],
"attributes": [
{
"attributeID": "comments",
"value": "add here any comment."
}
]
}

And the URL of the API call:

https://{base_url}/aps/2/services/order-manager/orders


The result of the request is:

"message": "com.parallels.pa.rest.BillingAPIFault: Access Denied. "


Cause

Customer is using the method to import NCE Microsoft  Subscription for a non based PLM plan. 


Resolution

For now we do not have a validated method to import Subscriptions based on Exclaimer products.