Symptoms


In recent billing order, it is observed that the detail type 'Discount' for previous subscription period was recharged. For example:


Cause


This is because the discount applied to the subscription was changed recently. For example, the subscription was using discount #123 with 5% discount previously, and then changed to discount #567 with 8% discount.

Currently, Rating Engine does not support the historical changes of discount. The change of discount has caused Rating Engine to consider that discount that was calculated previously are now incorrect and need to be recalculated. Therefore, it is recharging the discount amount given in the past and this is the reason why such details occur in the current billing order.

Feature request #PFR-6695 - 'Support historicity of discounts in RE' exist to improve this behavior. 


Resolution


If it is needed, please create a correction order to compensate the discount amount that was re-charged. More information regarding correcting orders can be found in official documentation Creating Correction for Order.