Symptoms
Sales order (SO) is stuck in Applying Credit Documents to Reseller-level Transactions (AD status) with message:
Attaching reseller standalone payment and credit memos. Error: Top-up payment was not created for Order #OrderNumber for Reseller #ResellerID.
Cause
Top-up option is misconfigured:
To check this please check top-up option status:
Login as Reseller >My Reseller Status > Check top-up option is not misconfigured
Top-up is not active: the default payment method is not available for payments:
Resolution
There are several options how this issue could be resolved. Either set a default payment method or disable top-up option.
To set a default payment method please follow below steps:
Login as Reseller > My Reseller Status > Payment Methods > Select Payment Method > Mark as Default
To disable Top-up option please follow below steps:
Login as Reseller > My Reseller Status > Edit > Unmark the Enable Top-up option