Symptoms


A reseller has installed HaloPSA from UX1 CP 'Integrations' >'Native Integrations' > 'Get Native Integrations' button, and the HaloPSA menu appears in the left side bar of the panel, but when accessing it, the below information is displayed:

HaloPSA Integration
To enable the integration:
 
Install MarketplaceAPI app and retrieve API access credentials
Go to your HaloPSA tool > Configuration > Integrations
Setup the integration with the API access credentials
 
See more details at https://halopsa.com/integrations/.


Cause


Halo integration is NOT a native integration, so in order to operate with PSA the MarketplaceAPI, as well know as SimpleAPI, has to be installed together with the HaloPSA integration.


Resolution


Prior to install and configure the HaloPSA for the reseller together with the MarketPlaceAPI, the provider must have installed and configured the SimpleAPI component by following the documentation:

https://docs.cloudblue.com/cbc/21.0/Simple-API/Introduction.htm


Once the simpleAPI component is installed and configured, Reseller must install the MarketplaceAPI component from Integrations > API Integrations > MarketplaceAPI, then click on 'Install now' button and wait until it's configured.

This will return the API access credentials for the reseller, then it will be required to contact the Halo support to complete the  onboard and configure the HaloPSA too.