Symptoms


It is observed that in UX1 > Application tab (eg: Exchange Online), a warning error 'Warning! This subscription has a pending order. Please wait until we process this request' appear despite despite the fact that the subscription does not have any incomplete orders. For example:


Cause


Such situation occur in case the request '/aps/2/services/order-manager/orders' returned an empty array. The issue was recognized as a software related issue #PDI-2119 - 'pending order warning message in case of no orders'


Resolution


The fix is considered to be included in one of the next PLM/PDI updates. Please contact Technical Account Manager to know the status of the software related issue.