Symptoms


While trying to upload Usage Report at Provider Control Panel > UX1 > Usage Reports > Upload Report, the error displayed:

PC_040 :: Cannot find secondary unit <UOM> in list of secondary units [] for ProductItem with sku <SKU>


Cause


Software issue RE-3061, where Usage Report won't be processed because on the UOM creation step "en" prefix is added to its name. RE should consider this prefix as the language prefix but it's instead considering as part of the UOM name, hence not finding it in the DB.



Resolution


Please communicate with your TAM or check release notes on our sites for further news on RE-3061 fix.