Symptoms


It is observed that when an order was placed with adjusted prices, the order was calculated with different prices that the one specified during checkout.

For example, the price adjusted in checkout screen is $53, after placing the order, the order was calculated with price $50.



Cause


The reported issue was caused by software related issue #OA-35380 - 'Incorrect special pricing being applied to orders with multiple products' where 'OrderID' is not taken into the account when suitable special pricing 'PromoID' is being searched on Sales Order placement. 

In this case, any special pricing which was configured for the same account and the same plan period will be selected from database, and therefore, the same price applied previously, was also applied for new subscriptions.



Resolution


The issue has been fixed in BSS-21.11.124. Please contact your Technical Account Manager to arrange installing it to your environment.