Symptoms


After shifting subscription to Rating Engine, subscription was billed with zero billing order.


Cause


It is the expected behavior of the system. Such issue will only occur on subscriptions with missing Migration Orders or Sales Orders.

Rating engine do not support subscriptions with such condition because it depends on the history of the subscription purchases (SO or MO must exist), in order to calculate charges. 


By default, Rating Engine migrator does not allow to shift such subscriptions to Rating Engine, as per described in existing feature request #PFR-6051 - 'Migrator can't get orders from archive tables'.

In this specific case, manual manipulations was done to pushed the subscriptions to get shifted to Rating Engine and eventually, it leads to incorrect billing of the shifted subscription.


Resolution


In order to fix the issue, it is required to reimport affected subscriptions using migration orders. Already generated Billing Order cannot be re-generated, therefore, if it is needed, please create a Debit Memo, to compensate the missing billing total using the formula:

Unit Price * Duration * Quantity = Extended Price.