Symptoms

Sales Order failed with below error:


The order provisioning failed.
The last error is "Service Creation Failed: Task "Provisioning "Tenant" for APS application inhouse-products(https://inhouse-products:8081/rest)" (id = 71706305) is failed with error: "'500 Internal Server Error' received from 'POST https://inhouse-products:8081/rest/tenant': Operation 'CREATION' failed. Fulfillment Request 'PR-1234-5678-6254-001'. Reason: There has been an error on checkout the cart: For the current term, the requested number of X asset(s) exceeded the remaining limit of Y assets allowed for this customer for the CatalogID - XXXXXXXX:XXXX


Cause

The Above Error Message is coming directly from Microsoft. The response from Microsoft can be found in the connect logs:


PR-1234-5678-6254-001 MICROSOFT_AAD_API_Response MS-CorrelationId:"xxxxxxxxxxxxxx", MS-RequestId:"xxxxxxxx" : {'orderErrors': [{'orderGroupId': '0', 'code': 800106, 'description': 'For the current term, the requested number of 1 asset(s) exceeded the remaining limit of 0 assets allowed for this customer for the CatalogID - XXXXXXXXX:0005:XXXXXXX.', 'attributes': {'objectType': 'OrderError'}}], 'additionalInformation': [], 'attributes': {'objectType': 'CartCheckoutResult'}}


Resolution


1. Check the PR status on the Connect side: 



2. Cancel the current order as it will never be completed.


3. To clarify the root cause, please get in touch with Microsoft Technical Support with MS CustomerID, MS-RequestId and CatalogID.