Symptoms


On integration with external fulfillment system, the renewal task ("Delivering of event notification Renew subscription period") keep rescheduling despite receiving 500 Internal Server Error from the external fulfillment system.

The same error works fine for Provisioning, Unprovisioning and Limit Change, which will mark the task as fail once the task received 500 Internal Server Error.


In Inhouse-products pod logs, retrieved by using kubectl logs inhouse-products-xxxxx-yyyyy, you can see that that TenantService task keep repeating after the initial 500 Internal Server Error:

11-09-2023;11:23:44,073+0200 INFO  [task:12162421:31329 application-rest:task-17 inhouse-products] c.o.p.application.rest.TenantService - updating tenant with uid a2653051-473e-4d12-ab5e-2753bc91408e - process instance: CamundaProcessInstance{id='6d669bc4-5079-11ee-b635-da1e64a26e39', businessKey='1019039:a2653051-473e-4d12-ab5e-2753bc91408e:8ee47dbe-cdbc-4bf3-826e-1c63805aaab8', variables={ext_id_activationDate=
CamundaCommonVariable{name='Activation Date', value='', type='string', showToCustomer=false, phase='fulfillment'}, ext_id_vendorSubscriptionId=CamundaCommonVariable{name='Vendor Subscription ID', value='', type='string', showToCustomer=false, phase='fulfillment'}, activationcode=CamundaCommonVariable{name='activationcode', value='PRODUCT-1Y-RECUR', type='string', showToCustomer=true, phase='fulf
illment'}}, state=ACTIVE, fulfillmentOperation=null}, fulfillment operation: RENEWAL, tenant entity: APSDynamicEntity{properties={tenantStatus=PENDING_FULFILLMENT, lastOperation=RENEWAL}}


Cause


Software related issue with id #PDI-2437, where TenantService task does not check the received error status.


Resolution


The fix is planned to be released in future version of inhouse-products.

Please contact your TAM or check our release notes to keep track the status of this issue.