Symptoms


Provider wants to upload new PPR file in UX1-UI classic mode by clicking the Import button on 'Portfolio > Products' menu. 


After a few seconds nothing happened. No error, warning, summary nor notification came up on UX1.


In browser dev mode we see an error similar to this one:

{
  "error": "com.ingrammicro.imcp.library.aps.exception.APSError",
  "packageId": "xxxxx-xxxxx-xxxx-xxxxx-xxxxxxxxxx",
  "message": "Column 'ServicePlan' of sheet 'DownsizePolicies' mentions following service plans not mentioned in the column 'Name_EN' of sheet 'ServicePlans': \"Microsoft 365 Business Basic (NCE COM MTH)\"<br/>Column 'ServicePlan' of sheet 'CancelationPolicies' mentions following service plans not mentioned in the column 'Name_EN' of sheet 'ServicePlans': \"Microsoft 365 Business Basic (NCE COM MTH)\"<br/>Column 'ServicePlan' of sheet 'PlanPeriods' mentions following service plans not mentioned in the column 'Name_EN' of sheet 'ServicePlans': \"Microsoft 365 Business Basic (NCE COM MTH)\"<br/>Column 'ToResource' of sheet 'UpgradeResourceMapping' mentions following resources not mentioned in the column 'Name_EN' of sheet 'Resources': \"Microsoft 365 Business Basic\"<br/>Following products were not found for account #1 in service template #323: Dynamics 365  Operations – Order Lines, Microsoft Sales Copilot Trial, Microsoft Entra ID P1, Microsoft Entra ID P2, Microsoft Sales Copilot",
  "http_request": "POST https://inhouse-products:8081/rest/application/7eeb6287-651e-462b-8a80-dc9dddfb4fea/parseConfig"
}


Cause


Such behavior was identified as software related issue with id #OA-35806 "Notifications.add do not work in "old" experience".


Resolution


OA-35806 was fixed in OA 21.13. Update to version 21.13 or higher. In the meantime, the New experience menu can be used by by activating the 'New Experience' button on top right corner in provider UX1 Control Panel.