Symptoms

Placed Cancellation Order that does not create a corresponding request on Connect and fails due following error:

Activation Date cannot be earlier than the subscription creation date or than the date of its last modification


Most likely there is a previous Cancellation Order already canceled can be found in the subscription history, but reviewing the task manager from the Operations side there is a failed task from this previous cancellation order that has been stuck.


Cause

Subscription is in inconsistent status due to the stuck task. Subscription is already disabled on OA which creates the misalignment.


Resolution


This order will never get completed. To be able to cancel your subscription please follow the next steps:

  1. Cancel failed task from a previous order
  2. Create a request to CloudBlue Technical Support to cancel CL in "Date Validation failed" status
  3. After the order has already been canceled place a new Cancellation Order