Symptoms


Place a NCE order that gets completed on Connect side, but on CloudBlue Commerce (CBC) falls into "Date Validation failed" with following error message:

Activation Date cannot be in the future.


Check the "provisioning items" tab and see under "Activation Date" that it is near future or even already passed. 


On the Operations side of the platform, under task manager, the "Activate scheduled subscription changes" task for this order is already successful, but its finish time is before the Activation Date from the order.


Cause


This is due the fact that current NCE plan has no Vendor Timezone configured, or it is configured in different timezone than the rest of the platform. 


For NCE Service Plans it is required to have Vendor Timezone correctly configured.


Resolution


Correct Vendor Timezone through PPR import. If after update Service Plan the issue persists, please kindly contact CloudBlue Technical Support.