Symptoms


Auto-renewal setting generates an empty request to Connect. The product does not have editable parameters for Change Requests and the subscription does not have any Pay as You Go items.


Cause


If the Manufacturer Part Number (MPN) has been changed in the item definition (Subscription Request > Reservation) between two requests, Connect does not reject the Change Request with no item changes.


If the MPN for an item is changed between two requests (the last request is the change one with no item changes) in the product definition on the vendor side, Connect considers that the MPN should be updated for the existing subscription and allows the change request, even if they do not have any other changes. So this case is valid from Connect POV.


Resolution


If you have such requests, it is fine. The request is valid and everything is fine, it was not an "empty" request. The MPN value was updated to match vendor's side.