Symptoms


After upgrading to UX1MP-7.2.1707, unable to resume reseller's marketplace where it shows the same error as per the following article: Resume Marketplace Failed With Error "You need to restart 'UX1 Marketplace [GUID] Plan indexer task"


Even after applying the same steps as per the article, the same error still persist.


On marketplace connector log, retrieve by using kubectl logs ux1-marketplace-connector-yyyy-zzzz, we can see the following OutOfMemory error:

2023-08-07T05:51:14.074451683Z stdout F 2023-08-07 05:51:14.074 +00:00 [INF] [no-tran] Route matched with {action = "UpdateIndex", controller = "Search"}. Executing controller action with signature Microsoft. AspNetCore.Mvc.IActionResult UpdateIndex(System.String, Boolean) on controller Endpoint.Controllers.SearchController (endpoint-app). 2023-08-07T05:51:14.074572459Z stdout F 2023-08-07 05:51:14.074 +00:00 [INF] [no-tran] Async task 'updateIndex' was failed 2023-08-07T05:51:14.075702183Z stdout F 2023-08-07 05:51:14.075 +00:00 [ERR] [no-tran] System.AggregateException: One or more errors occurred. (Exception of type 'System.OutOfMemoryException' was thrown.) 2023-08-07T05:51:14.075732029Z stdout F  ---> System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown. 2023-08-07T05:51:14.075738802Z stdout F    at System.Collections.Generic.Dictionary`2.Initialize(Int32 capacity) in /_/src/System.Private.CoreLib/shared/System/Collections/Generic/Dictionary.cs:line 475 2023-08-07T05:51:14.075743911Z stdout F    at System.Collections.Generic.Dictionary`2.TryInsert(TKey key, TValue value, InsertionBehavior behavior) in /_/src/System.Private.CoreLib/shared/System/Collections/Generic/Dictionary.cs:line 480 2023-08-07T05:51:14.07574835Z stdout F    at System.Collections.Generic.Dictionary`2.System.Collections.IDictionary.set_Item(Object key, Object value) in /_/src/System.Private.CoreLib/shared/System/Collection


Cause

Software related issue #CMP-10795 where plan indexer task consume huge memory.


Resolution


Currently the fix is still being worked on #CMP-10795.

Please contact your TAM to further track the status of this issue.