Symptoms
Sales Order failed with the following error:
The order provisioning failed. The last error is "Service Creation Failed: Task "Provisioning "subscriptionService" for APS application CSP Microsoft 365 Education(https://aps.connect.cloudblue.com/connector)" (id = XXXXXX) is failed with error: "'409 Conflict' received from 'POST https://aps.connect.cloudblue.com/connector/tenant': The purchase request PR-XXXX-XXXX-XXXX-XXX has not been completed. The vendor has rejected the request with following reason: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> Message from the Vendor: The customer is not qualified to purchase Education offers. >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> Important note: submitting again this order will fail due previous reason please create a new purchase request to correct it or contact support " Service Creation Failed: Service Creation Failed: Task "Provisioning "subscriptionService" for APS application CSP Microsoft 365 Education(https://aps.connect.cloudblue.com/connector)" (id = XXXXXX) is failed with error: "'409 Conflict' received from 'POST https://aps.connect.cloudblue.com/connector/tenant': The purchase request PR-XXXX-XXXX-XXXX-XXX has not been completed. The vendor has rejected the request with following reason: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> Message from the Vendor: The customer is not qualified to purchase Education offers. >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> Important note: submitting again this order will fail due previous reason please create a new purchase request to correct it or contact support "".
Cause
The issue can occur when the customer has no special qualification to purchase Education offers from the Microsoft side.
Resolution
1. Check the PR status on the Connect side:
2. Cancel the current order as it will never be completed as the customer has no special qualification from MSPC to purchase Education offers.