Symptoms

Sales Order failed with the following error:


The order provisioning failed.
The last error is "Service Creation Failed: Task "Provisioning "subscriptionService" for APS application CSP Microsoft 365 Education(https://aps.connect.cloudblue.com/connector)" (id = XXXXXX) is failed with error: "'409 Conflict' received from 'POST https://aps.connect.cloudblue.com/connector/tenant':

The purchase request PR-XXXX-XXXX-XXXX-XXX has not been completed.
The vendor has rejected the request with following reason:

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Message from the Vendor: Customer's domain is not considered affiliated with an Education institution, if you would like to dispute this: please engage Microsoft Support.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Important note: submitting again this order will fail due previous reason
please create a new purchase request to correct it or contact support
"".
Please check the "Provisioning item" (details) and the last items of the "Service Status History" (details) of the associated subscriptions for more details. As soon as you fix the problem, resubmit this order for provisioning.
Additional information about this error in Platform Knowledge Base - Click here to find a solution


Cause


The issue can occur when the customer has no special qualification to purchase Education offers from the Microsoft side.


Resolution


1. Check the PR status on the Connect side:  



2. Cancel the current order as it will never be completed as the customer has no special qualification from MSPC to purchase Education offers.


3. As it described in Microsoft documentation, the partner's tenant should be registered and verified in a special way in order to obtain the ability to provide subscriptions based on Education offers.
Please contact Microsoft Support in order to obtain details about the tenant creation and verification process.