Symptoms


In Operations Tasks Manager, task /updateCustomerTrend is failed exactly one hour after start with "Read timed out" error:

RESTEASY004655: Unable to invoke request: java.net.SocketTimeoutException: Read timed out
Read timed out


Cause


Update task take more than an hour to complete on the Reporting and Data Export Database. However, updateCustomerTrend on the oss side can only wait a reply from the update from the Reporting and Data Export side up to 1 hour, this lead to failed task due time out. But update task still runs on the RDE side until complete.


It is considered as a software related issue with ID #RDEX-511 that will be fixed in future RDE releases.


Resolution


As explained, this task will never complete on task manager even if it is completed on the RDE side, so this task can be ignored or cancelled.